Lost connection: This server requires you to install the Origins mod (v1.3.1) to play

I’m running a Velocity proxy with a vanilla world and a modded fabric world. I’m able to join the vanilla world fine, but when I try to connect to the Fabric world, it gives me an error telling me to install the Origins mod (one of the mods on the Fabric server). However, I have the mod installed on my client and I know that it’s the same version. I’ve tried installing CrossStitch and FabricProxy-Lite. Any idea what I should try next?