VelocityAutoReconnect | Automatic reconnection for Velocity

Automatic reconnection for Velocity

If you find a bug or would like to suggest a feature addition, please open an issue on GitHub. Known bugs and upcoming features may be found there as well.

Features:

  • Automatic reconnection from fallback server to previous server
  • Filtering players connecting to the fallback server by kick reason to disconnect kicked/banned players
  • Sending a message to players joining the fallback server
  • Redirection of players that are sent to the fallback server initially to a default server (1.1.x)

Setup and Configuration:
See documentation.

VelocityAutoReconnect 1.1.0 has been released.

Players that were directly connected to the fallback server on join by Velocity are now redirected to a default server specified under directconnect-server in the config.

Automatically fetching a server depending on forced hosts and the default try order is planned for the next release.

VelocityAutoReconnect 1.1.1 has been released

Fixed direct connection handling added in 1.1.0. All listeners are now unregistered when a required configuration option is invalid.

VelocityAutoReconnect 1.1.2 has been released
Fixed the last fix ._.

v1.1.1 broke autoreconnection on kick

VelocityAutoReconnect 1.2.0 has been released
A ping check has been added to avoid spamming players and the console.

VelocityAutoReconnect 1.2.1 has been released

  • Refactored code
  • Prevented console spam when a player can’t connect and the ping check is disabled

VelocityAutoReconnect 1.2.2 has been released

Critical bug fix

  • v1.2.1 broke server properties, servers are now properly selected again

Other

  • Now using Java 11
  • Now built against Velocity 3.0.0 API

VelocityAutoReconnect 1.2.3 has been released

Major bug fix

  • Fixed kick reason filter

Tried to match kick reason filter regex against Component.toString(), which returns the String representation of either a TranslatableComponent or a TextComponent, leading to unexpected behavior. Did the white/blacklist ever work? It seemed to work on my 1.16 network. Let’s hope that was the case, since the whitelist option was enabled by default… At least it works now.